Run "helloworld" error as ROS user

Hello, I run HelloWorld as the orocos components maual tell. first $ rosrun ocl orocreate-pkg HelloWorld # ... for ROS users,,,,,this step is no problem. Then $ cd HelloWorld

      $ make
I got a message. Linking CXX shared library make[3]: Leaving directory `/home/human/HelloWorld/build' [100%] Built target HelloWorld-transport-corba-gnulinux make[2]: Leaving directory `/home/human/HelloWorld/build' make[1]: Leaving directory `/home/human/HelloWorld/build'

I throught I have already create HelloWorld application. then I Create an 'helloworld.ops' As the manual told.shows below. require("print") // necessary for 'print.ln' import("HelloWorld") // 'HelloWorld' is a directory name to import print.ln("Script imported HelloWorld package:") displayComponentTypes() // Function of the DeploymentComponent loadComponent("Hello", "HelloWorld") // Creates a new component of type 'HelloWorld' print.ln("Script created Hello Component with period: " + Hello.getPeriod() )

I run the $ deployer-gnulinux -s helloworld.ops -linfo I got an error.

0.268 [ ERROR ][DeploymentComponent::import] Failed to import components, types or plugins from package or directory 'HelloWorld' found in: 0.268 [ ERROR ][DeploymentComponent::import] HelloWorld:HelloWorld/gnulinux:/home/human/HelloWorld:./HelloWorld

0.286 [ ERROR ][DeploymentComponent::loadComponent] Unable to create Orocos Component 'HelloWorld': unknown component type. 0.286 [ ERROR ][ScriptingService] HelloWorld.ops :Parse error at line 6: Service or Task "Deployer" has no Peer or Service Hello (or Deployer was not found at all).

Then I run that. Deployer [S]> cd Hello It told me No such peer: Hello

So how can I figure it out.thanks a lot^_^


Have the same exact problem.

Can someone care to explain?

Best regards,